package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[blargh=(?|"(\d+)"|("[^"]*"))\]`)
var str = `[blargh="5"] [blargh="97"] [blargh="StackOverflow"]
`
var substitution = "<potato chips=#\1#>"
fmt.Println(re.ReplaceAllString(str, substitution))
}