re = /\[blargh=(?|"(\d+)"|("[^"]*"))\]/m
str = '[blargh="5"] [blargh="97"] [blargh="StackOverflow"]
'
subst = '<potato chips=#\\1#>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result