re = />\s*\K(?:(?!<).)+(?=<\/li)/
str = '<li class="video_description"><strong>Description:</strong> hello world, This is test description.</li>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end