package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[#]([1-9]|1[0123456789])[,][ ][#]([1-9]|1[0123456789])[,][ ][#]([1-9]|1[0123456789])[,][ ][#]([1-9]|1[0123456789])[,][ ][#]([1-9]|1[0123456789])`)
var str = `#8, #6, #3, #9, #16`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}