const regex = /((?<!\n)\n{2}(?!\n))|\n+/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?<!\\n)\\n{2}(?!\\n))|\\n+', 'gi')
const str = `
ashdh hjgsad
asdsad
asdasd
asdsadsa
sas
as
asfsads
2here
`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);