use strict;
my $str = '
ashdh hjgsad
asdsad
asdasd
asdsadsa
sas
as
asfsads
2here
';
my $regex = qr/((?<!\n)\n{2}(?!\n))|\n+/ip;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";