import Foundation
let pattern = #"((?<!\n)\n{2}(?!\n))|\n+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
ashdh hjgsad
asdsad
asdasd
asdsadsa
sas
as
asfsads
2here
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)