using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""[^""]*""(*SKIP)(*F)|Dog";
string substitution = @"Cat";
string input = @"Dogs are scary but my mom told me that ""Dogs are cute""";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}