package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)"[^"]*"(*SKIP)(*F)|Dog`)
var str = `Dogs are scary but my mom told me that "Dogs are cute"`
var substitution = "Cat"
fmt.Println(re.ReplaceAllString(str, substitution))
}