re = /"[^"]*"(*SKIP)(*F)|Dog/i
str = 'Dogs are scary but my mom told me that "Dogs are cute"'
subst = 'Cat'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result