import Foundation
let pattern = #""[^"]*"(*SKIP)(*F)|Dog"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"Dogs are scary but my mom told me that "Dogs are cute""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"Cat"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)