const regex = /Dogs(?=(?:[^"]*"[^"]*")*[^"]*$)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Dogs(?=(?:[^"]*"[^"]*")*[^"]*$)', 'gi')
const str = `Dogs are scary.
Dogs are scary but my mom told me that "Dogs are cute"`;
const subst = `Cats`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);