#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\/p\/(?:.*\/)?(\d+)\b"
Local $sString = "http://www.example.com/p/12345678" & @CRLF & _
"http://www.example.com/p/12345678?foo=bar" & @CRLF & _
"http://www.example.com/p/some-text-123/1234567890?foo=bar"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")