$re = '/(?:\(|(?<!^)\G)[^)"]*\K"([^"]*)"/';
$str = '"false" ("first" or "second") "false" ("third (with parenthesis)")';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;