$re = '/^[^0|\D]\d{0,9}(\.\d{1,2})?$/';
$str = '12323.23';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);