using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"barcode\?message=(.+)(\n)(.+)""";
string input = @"<img alt=""Barcode for scanning boarding pass"" height =""287"" width=""287"" src=""/checkin/pass/barcode?message=TTEvU0FMTFkgICAgICAgICAgICAgIEUyNDZINVkgU1lEU1lEUUYgMDQwNyAxMDRZMDMxRTAwMDUg
MzU5PjIxODAgTSAgICBCICAgICAgICAgICAgICAgIDI5ICAgICAgICAgICAgIDAgICAgICAgICAgICAgICAgICAgICAgICAgICAgICAgICAgICAgICAgICAgICA="" />
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}