import Foundation
let pattern = #"barcode\?message=(.+)(\n)(.+)""#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<img alt="Barcode for scanning boarding pass" height ="287" width="287" src="/checkin/pass/barcode?message=TTEvU0FMTFkgICAgICAgICAgICAgIEUyNDZINVkgU1lEU1lEUUYgMDQwNyAxMDRZMDMxRTAwMDUg
MzU5PjIxODAgTSAgICBCICAgICAgICAgICAgICAgIDI5ICAgICAgICAgICAgIDAgICAgICAgICAgICAgICAgICAgICAgICAgICAgICAgICAgICAgICAgICAgICA=" />
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}