using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\\doc(.*?)\\in";
string input = @"\doc doc1,doc2
\doc doc1,doc2 \in filed1,field2
\doc doc1,doc2 \in filed1,field2 \doc doc3,doc4 \in field3,field4";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}