using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^<a[^>]*href=""([^""]+)""[^>]*([^<]+).*$";
string substitution = @"<navpoint id=""n"" playOrder="">\n<navLabel><text>$2</text></navLabel>\n<content src=""$1"" />\n</navpoint>\n";
string input = @"<a href=""final/main.html"">Multimedia Implementation</a><br/>
<a href=""final/toc.html"">Table of Contents</a><br/>
<a href=""final/pref01.html"">About the Author</a><br/>
<a href=""final/pref02.html"">About the Technical Reviewers</a><br/>
<a href=""final/pref03.html"">Acknowledgments</a><br/>
<a href=""final/part01.html"">Part I: Introduction and Overview</a><br/>
<a href=""final/ch01.html"">Chapter 1. Technical Overview</a><br/>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}