Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Regular
Expressions
101
Regular
Expressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
^<a[^>]*href="([^"]+)"[^>]*([^<]+).*$
/
gm
Test String
New
<a href="final/main.html">Multimedia Implementation</a><br/> <a href="final/toc.html">Table of Contents</a><br/> <a href="final/pref01.html">About the Author</a><br/> <a href="final/pref02.html">About the Technical Reviewers</a><br/> <a href="final/pref03.html">Acknowledgments</a><br/> <a href="final/part01.html">Part I: Introduction and Overview</a><br/> <a href="final/ch01.html">Chapter 1. Technical Overview</a><br/>
Substitution
Processing...
<navpoint id="n" playOrder="">\n<navLabel><text>$2</text></navLabel>\n<content src="$1" />\n</navpoint>\n