# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[^^](.*)\n(--+)"
test_str = ("The case of a file name is one thing, but the case of formatting code in\n"
"a source file is a different matter. Almost all languages have an agreed\n"
"upon style of casing, indentation, etc. You should make a real effort to\n"
"discover the strategy for the language you are using, and to follow it\n"
"as best you can. In this document, I attempt to follow the standards for\n"
"formatting JavaScript code. With a few minor exceptions, if you see me\n"
"vary from what you consider to be the best strategy for formatting\n"
"JavaScript, then please send me email and let me know. My goal is to\n"
"conform to the standards set by the JavaScript community. If I want to\n"
"assert my individuality, I wrote prose or poetry; when I write code, I\n"
"try to conform to standards. The only case for individuality in code is\n"
"the case for writing the cleanest, easiest to understand code of any\n"
"developer on your team. There is no place for a quirky style of\n"
"capitalization or indentation.\n\n"
"A Simple JavaScript Development Strategy\n"
"----------------------------------------\n\n"
"JavaScript run in the browser has one set of rules when run in a\n"
"browser, and another set when run outside a browser. If you are using\n"
"JavaScript primarily to write client side scripts meant to be run in a\n"
"browser, then it is best to learn JavaScript, and develop JavaScript,\n"
"under that scenario. It is true that there are legitimate and important\n"
"ways to run JavaScript from outside the browser. For instance, you can\n"
"run JavaScript from the command prompt, or directly from inside some\n"
"IDEs. At first, however, such stratagems can lead to much confusion. As\n"
"a result, I suggest that you begin by developing JavaScript inside a\n"
"browser.")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.