# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?<FirstLine>(?<Passport>P)(?<PassportType>.)(?<IssuingCountry>\w{3})(?<PassportOwner>(?<Surname>\w+)<<(?<GivenName>(?:[\w]+<?)+)[<]+))\n(?<SecondLine>(?<PassportNumber>[a-zA-Z0-9<]{9})(?<CheckDigit19>[0-9]{1})(?<Nationality>[A-Za-z]{3})(?<DoB>[0-9]{6})(?<CheckDigit1419>[0-9])(?<Sex>[MF<])(?<Expiral>[0-9]{6})(?<CheckDigit2227>[0-9])(?<PersonalNumber>[\w<]{14})(?<CheckDigit2942>[0-9<])(?<CheckDigitF>[0-9]))$"
test_str = ("P<UTOERIKSSON<<ANNA<MARIA<<<<<<<<<<<<<<<<<<<\n"
"L898902C<3UTO6908061F9406236ZE184226B<<<<<14\n\n\n\n\n\n")
matches = re.search(regex, test_str, re.MULTILINE)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.