// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?<FirstLine>(?<Passport>P)(?<PassportType>.)(?<IssuingCountry>\w{3})(?<PassportOwner>(?<Surname>\w+)<<(?<GivenName>(?:[\w]+<?)+)[<]+))\n(?<SecondLine>(?<PassportNumber>[a-zA-Z0-9<]{9})(?<CheckDigit19>[0-9]{1})(?<Nationality>[A-Za-z]{3})(?<DoB>[0-9]{6})(?<CheckDigit1419>[0-9])(?<Sex>[MF<])(?<Expiral>[0-9]{6})(?<CheckDigit2227>[0-9])(?<PersonalNumber>[\w<]{14})(?<CheckDigit2942>[0-9<])(?<CheckDigitF>[0-9]))$").unwrap();
let string = "P<UTOERIKSSON<<ANNA<MARIA<<<<<<<<<<<<<<<<<<<
L898902C<3UTO6908061F9406236ZE184226B<<<<<14
";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}