re = /(?i)(?:(?<=\d)(?=[a-z])|(?<=[a-z])(?=\d))/
str = 'subject101
street45'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result