using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"=hyperlink\(""([@\\\w\s\(\)\-\.\/]+\\([^""]+))""\)";
string substitution = @"<a href=""file:///$1"">$2</a>";
string input = @"=hyperlink(""\\share\folder\log\2013\13-05-13\13-05-13.txt"")";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}