use strict;
my $str = '=hyperlink("\\\\share\\folder\\log\\2013\\13-05-13\\13-05-13.txt")';
my $regex = qr/=hyperlink\("([@\\\w\s\(\)\-\.\/]+\\([^"]+))"\)/ip;
my $subst = '<a href="file:///$1">$2</a>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";