#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[\w][\S]{0,8}$"
Local $sString = "Hello!@+" & @CRLF & _
"t123123" & @CRLF & _
"H123!#" & @CRLF & _
"@adadsa" & @CRLF & _
"@3asdasd" & @CRLF & _
"%sdf" & @CRLF & _
"Helloworld1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")