package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[\w][\S]{0,8}$`)
var str = `Hello!@+
t123123
H123!#
@adadsa
@3asdasd
%sdf
Helloworld1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}