// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[\w][\S]{0,8}$").unwrap();
let string = "Hello!@+
t123123
H123!#
@adadsa
@3asdasd
%sdf
Helloworld1";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}