#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?=[\r\n]+)\s*([0-9]+[\/][^\r\n\s])+\s*[0-9][^\r\n]*[\r\n]+"
Local $sString = "WIRES" & @CRLF & _
"Wire Details Actions: Go Print Close" & @CRLF & _
"Rec'd Date/Time (EST) Sender ST Wire Type/Title Master Message # Deal Type" & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
"RE: $ 437,025,000" & @CRLF & _
"CITY OF AURORA, COLORADO" & @CRLF & _
"ACTING BY AND THROUGH ITS UTILITY ENTERPRISE" & @CRLF & _
"FIRST LIEN WATER REFUNDING BONDS, SERIES 2016" & @CRLF & _
"(GREEN BONDS)" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
"LADIES AND GENTLEMEN:" & @CRLF & _
" " & @CRLF & _
"WE HAVE RECEIVED THE WRITTEN AWARD. TODAY, JULY 22ND WILL BE INITIAL TRADE DATE." & @CRLF & _
"TIME OF FIRST EXECUTION IS 11:00AM EST." & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" MOODY'S: NR S&P: AA+ FITCH: AA+ " & @CRLF & _
" " & @CRLF & _
" DATED:08/16/2016 FIRST COUPON:02/01/2017" & @CRLF & _
" " & @CRLF & _
" DUE: 08/01 " & @CRLF & _
" " & @CRLF & _
" INITIAL TRADE DATE: 07/22/2016 @ 11:00AM Eastern" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
"MATURITY AMOUNT COUPON PRICE CUSIP " & @CRLF & _
"08/01/2020 2,350M 1.50% 0.83 051595AL0" & @CRLF & _
" (Approx. $ Price 102.603) " & @CRLF & _
"08/01/2021 4,855M 5.00% 0.97 051595AM8" & @CRLF & _
" (Approx. $ Price 119.462) " & @CRLF & _
"08/01/2022 7,565M 5.00% 1.13 051595AN6" & @CRLF & _
" (Approx. $ Price 122.238) " & @CRLF & _
"08/01/2023 10,410M 5.00% 1.28 051595AP1" & @CRLF & _
" (Approx. $ Price 124.689) " & @CRLF & _
"08/01/2024 1,625M 3.00% 1.40 051595AQ9" & @CRLF & _
" (Approx. $ Price 112.009) " & @CRLF & _
"08/01/2024 9,305M 5.00% 1.40 051595BE5" & @CRLF & _
" (Approx. $ Price 127.021) " & @CRLF & _
"08/01/2025 11,445M 5.00% 1.52 051595AR7" & @CRLF & _
" (Approx. $ Price 129.042) " & @CRLF & _
"08/01/2026 4,000M 4.00% 1.65 051595AS5" & @CRLF & _
" (Approx. $ Price 121.498) " & @CRLF & _
"08/01/2026 8,015M 5.00% 1.65 051595BJ4" & @CRLF & _
" (Approx. $ Price 130.646) " & @CRLF & _
"08/01/2027 12,015M 5.00% 1.76 051595AT3" & @CRLF & _
" (Approx. $ Price PTC 08/01/2026 129.476 Approx. YTM 1.992) " & @CRLF & _
"08/01/2028 12,615M 5.00% 1.87 051595BF2" & @CRLF & _
" (Approx. $ Price PTC 08/01/2026 128.318 Approx. YTM 2.281) " & @CRLF & _
"08/01/2029 13,245M 5.00% 1.93 051595AU0" & @CRLF & _
" (Approx. $ Price PTC 08/01/2026 127.691 Approx. YTM 2.487) " & @CRLF & _
"08/01/2030 13,905M 5.00% 1.98 051595BG0" & @CRLF & _
" (Approx. $ Price PTC 08/01/2026 127.172 Approx. YTM 2.657) " & @CRLF & _
"08/01/2031 14,600M 5.00% 2.03 051595AV8" & @CRLF & _
" (Approx. $ Price PTC 08/01/2026 126.655 Approx. YTM 2.806) " & @CRLF & _
"08/01/2032 6,045M 4.00% 2.33 051595AW6" & @CRLF & _
" (Approx. $ Price PTC 08/01/2026 114.764 Approx. YTM 2.843) " & @CRLF & _
"08/01/2032 8,835M 5.00% 2.08 051595BM7" & @CRLF & _
" (Approx. $ Price PTC 08/01/2026 126.141 Approx. YTM 2.936) " & @CRLF & _
"08/01/2033 15,565M 5.00% 2.13 051595AX4" & @CRLF & _
" (Approx. $ Price PTC 08/01/2026 125.629 Approx. YTM 3.053) " & @CRLF & _
"08/01/2034 16,345M 5.00% 2.18 051595AY2" & @CRLF & _
" (Approx. $ Price PTC 08/01/2026 125.119 Approx. YTM 3.157) " & @CRLF & _
"08/01/2035 17,160M 5.00% 2.22 051595AZ9" & @CRLF & _
" (Approx. $ Price PTC 08/01/2026 124.714 Approx. YTM 3.244) " & @CRLF & _
"08/01/2036 18,020M 5.00% 2.26 051595BA3" & @CRLF & _
" (Approx. $ Price PTC 08/01/2026 124.310 Approx. YTM 3.324) " & @CRLF & _
" " & @CRLF & _
"08/01/2041 40,000M 3.00% 2.90 051595BK1" & @CRLF & _
" (Approx. $ Price PTC 08/01/2026 100.858 Approx. YTM 2.951) " & @CRLF & _
" " & @CRLF & _
"08/01/2041 62,915M 5.00% 2.32 051595BD7" & @CRLF & _
" (Approx. $ Price PTC 08/01/2026 123.706 Approx. YTM 3.559) " & @CRLF & _
" " & @CRLF & _
"08/01/2046 45,000M 2.00% 100.00 051595BB1" & @CRLF & _
"**STEP COUPON " & @CRLF & _
" " & @CRLF & _
"08/01/2046 25,000M 3.00% 2.95 051595BL9" & @CRLF & _
" (Approx. $ Price PTC 08/01/2026 100.427 Approx. YTM 2.978) " & @CRLF & _
" " & @CRLF & _
"08/01/2046 5,000M 4.00% 2.62 051595BH8" & @CRLF & _
" (Approx. $ Price PTC 08/01/2026 112.026 Approx. YTM 3.360) " & @CRLF & _
" " & @CRLF & _
"08/01/2046 51,190M 5.00% 2.37 051595BC9" & @CRLF & _
" (Approx. $ Price PTC 08/01/2026 123.206 Approx. YTM 3.710) " & @CRLF & _
" " & @CRLF & _
" ---------------------------------------" & @CRLF & _
" " & @CRLF & _
"CALL FEATURES: Optional call in 08/01/2026 @ 100.00" & @CRLF & _
" " & @CRLF & _
"EXCEPT:" & @CRLF & _
" 08/01/2046 Optional call in 08/01/2019 @ 100.00 Coupon: 2.000" & @CRLF & _
"**THE STEP COUPON BONDS WILL BEAR INTEREST EACH PERIOD AS FOLLOWS:" & @CRLF & _
" " & @CRLF & _
"FROM TO (AND INCLUDING) INTEREST RATE" & @CRLF & _
"--------- ------------------ -------------" & @CRLF & _
"08/16/2016 07/31/2019 2.000%" & @CRLF & _
"08/01/2019 07/31/2026 2.250%" & @CRLF & _
"08/01/2026 07/31/2031 3.500%" & @CRLF & _
"08/01/2031 07/31/2041 4.500%" & @CRLF & _
"08/01/2041 08/01/2046 5.000%" & @CRLF & _
" " & @CRLF & _
" ---------------------------------------" & @CRLF & _
" " & @CRLF & _
" Sinking Fund Schedule" & @CRLF & _
" " & @CRLF & _
"2041 Term Bond" & @CRLF & _
" " & @CRLF & _
"08/01/2037 7,535M" & @CRLF & _
"08/01/2038 7,760M" & @CRLF & _
"08/01/2039 7,995M" & @CRLF & _
"08/01/2040 8,230M" & @CRLF & _
"08/01/2041 8,480M" & @CRLF & _
" " & @CRLF & _
" Sinking Fund Schedule" & @CRLF & _
" " & @CRLF & _
"2041 Term Bond" & @CRLF & _
" " & @CRLF & _
"08/01/2037 11,385M" & @CRLF & _
"08/01/2038 11,955M" & @CRLF & _
"08/01/2039 12,550M" & @CRLF & _
"08/01/2040 13,185M" & @CRLF & _
"08/01/2041 13,840M" & @CRLF & _
" " & @CRLF & _
" Sinking Fund Schedule" & @CRLF & _
" " & @CRLF & _
"2046 Term Bond" & @CRLF & _
" " & @CRLF & _
"08/01/2042 8,145M" & @CRLF & _
"08/01/2043 8,550M" & @CRLF & _
"" & @CRLF & _
"08/01/2044 8,980M" & @CRLF & _
"08/01/2045 9,425M" & @CRLF & _
"08/01/2046 9,900M" & @CRLF & _
" " & @CRLF & _
" Sinking Fund Schedule" & @CRLF & _
" " & @CRLF & _
"2046 Term Bond" & @CRLF & _
" " & @CRLF & _
"08/01/2042 4,710M" & @CRLF & _
"08/01/2043 4,850M" & @CRLF & _
"08/01/2044 4,995M" & @CRLF & _
"08/01/2045 5,145M" & @CRLF & _
"08/01/2046 5,300M" & @CRLF & _
" " & @CRLF & _
" Sinking Fund Schedule" & @CRLF & _
" " & @CRLF & _
"2046 Term Bond" & @CRLF & _
" " & @CRLF & _
"08/01/2042 920M" & @CRLF & _
"08/01/2043 960M" & @CRLF & _
"08/01/2044 1,000M" & @CRLF & _
"08/01/2045 1,040M" & @CRLF & _
"08/01/2046 1,080M" & @CRLF & _
" " & @CRLF & _
" Sinking Fund Schedule" & @CRLF & _
" " & @CRLF & _
"2046 Term Bond" & @CRLF & _
" " & @CRLF & _
"08/01/2042 9,265M" & @CRLF & _
"08/01/2043 9,730M" & @CRLF & _
"08/01/2044 10,210M" & @CRLF & _
"08/01/2045 10,725M" & @CRLF & _
"08/01/2046 11,260M" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
"PRIORITY OF ORDERS:" & @CRLF & _
"1. Net Designated" & @CRLF & _
"(Except if an investor is affiliated with a syndicate member in which case the" & @CRLF & _
" economics will be reallocated among the other managers. Please contact the" & @CRLF & _
" Senior Manager.)" & @CRLF & _
"2. Individual Colorado Retail" & @CRLF & _
"3. Individual National Retail" & @CRLF & _
"4. Member" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
""Individual Colorado Retail Order" is defined as an order up to $1,000,000 placed on" & @CRLF & _
"behalf of an individual in Colorado. Larger Individual Colorado Retail Orders will be" & @CRLF & _
"accepted at the sole discretion of the City. All Individual Colorado Retail Orders must" & @CRLF & _
"include account numbers and zip codes." & @CRLF & _
" " & @CRLF & _
"An "Individual National Retail Order" is defined as an order up to $1,000,000 placed on" & @CRLF & _
"behalf of an individual outside of Colorado. Larger Individual National Retail Orders" & @CRLF & _
"will be accepted at the sole discretion of the City. All Individual National Retail" & @CRLF & _
"Orders must include account numbers and zip codes." & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
"Priority Policy:" & @CRLF & _
" " & @CRLF & _
"Morgan Stanley & Co. must receive 50% of each designation." & @CRLF & _
" " & @CRLF & _
"RBC Capital Markets must receive at least 20% of each designation." & @CRLF & _
" " & @CRLF & _
"Bank of America Merrill Lynch and Wells Fargo Securities must each be designated at least" & @CRLF & _
"10%." & @CRLF & _
" " & @CRLF & _
"No firm may receive more than 50% of each designation." & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
"The compliance addendum MSRB Rule G-11 will apply." & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
"The Award is expected on Thursday, July 21, 2016 at 5:10PM Eastern ." & @CRLF & _
" " & @CRLF & _
"Delivery is firm for Tuesday, August 16, 2016." & @CRLF & _
" " & @CRLF & _
"This issue is book entry only. This issue is clearing through DTC." & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
"Award: 07/21/2016 " & @CRLF & _
"Award Time: 5:10PM Eastern " & @CRLF & _
"Delivery: 08/16/2016 (Firm)" & @CRLF & _
"Initial trade: 07/22/2016 " & @CRLF & _
"Date of Execution: 07/22/2016 " & @CRLF & _
"Time of Execution: 11:00AM Eastern " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
"Electronic copies of the Preliminary Official Statement can be accessed via the following" & @CRLF & _
"link:" & @CRLF & _
"http://www.meritos.com/cgi-bin/disclaimer.pl?Did=2225" & @CRLF & _
" " & @CRLF & _
"Morgan Stanley & Co. LLC " & @CRLF & _
"RBC Capital Markets " & @CRLF & _
"Bank of America Merrill Lynch " & @CRLF & _
"Wells Fargo Securities (trade name for Wells Fargo " & @CRLF & _
"Bank N.A. Municipal Products Group) " & @CRLF & _
" " & @CRLF & _
"By: Morgan Stanley & Co. LLC New York, NY" & @CRLF & _
" Close" & @CRLF & _
"" & @CRLF & _
"Terms and Conditions of Use and Privacy Statement © 2016 Ipreo. All rights reserved." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")