const regex = /(?:\s|\r)+GO\s*(?:\r|\n)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\s|\\r)+GO\\s*(?:\\r|\\n)', 'g')
const str = `1111111
GO
222222222
GO
3333333333
GO
444444444444444
GO
55555555555555`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}