re = /(?:\s|\r)+GO\s*(?:\r|\n)/
str = '1111111
GO
222222222
GO
3333333333
GO
444444444444444
GO
55555555555555'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end