$re = '/(\b\w+\b |\b\w+\b$)(?!\1)/m';
$str = 'dog dog dog cat fish
dog dog cat fish';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);