package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:^| )(?<match>bi-.*?)(?:$|\s)`)
var str = `bi bi-envelope-fill text-red me-2 flex-shrink-0
bi-envelope-fill text-red me-2 flex-shrink-0
bi bi-envelope-fill
bibi-envelope-fill`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}