$re = '/1?[\ \.\(]?[N]{3}\)?[]\ \-\.][A][N]{2}[\ \-\.][N]{4}\)?/';
$str = 'NNN ANN NNNN
(NNN) ANN NNNN
NNN-ANN-NNNN
(NNN) ANN-NNNN
1NNN ANN NNNN
1(NNN) ANN NNNN
1NNN-ANN-NNNN
1(NNN) ANN-NNNN
NNN.ANN.NNNN
(NNN-ANN-NNNN)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);