// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m) \^https:\/\/drive\.google\.com\/.+\/folders\/([A-Za-z0-9_-]+=?)$/").unwrap();
let string = "https://drive.google.com/drive/u/3/folders/1UY_52juN_wDWxGfmi1KyWrOVA-jz-sYL?resourcekey=abcd123
";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}