package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Z][a-z]+\s[A-Z][a-z]+$`)
var str = `John Smith
John Smith Joe`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}