re = /(-[^-]{2}-[^-]|-[^-])(?=\/.*)/
str = 'H-Foo-Bar-cu-s/9.htm
Some-Thing-sb-s/22297.htm
Foo-Boo-or-Bar-cu-s/553.htm
Random-32-Ness-Can-be-Fun-cu-s/4617.htm
Chicken-Fried-264-Seaturtles-for-Pennies-cu-s/3971.htm
Asymetrical-Banana-Party-p/asy-banana-p.htm'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end