$re = '/^((\d,?){8})/m';
$str = '0,1,2,367,8,9,
0,1,2,,367,8,9,
0,1,2,367,8,9';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);