$re = '/[^ \w+%#()*+.,/:;<=>?€£¥§ÄÅÜäèéìñòöùü=“”‘’\'"-]/';
$str = 'This is a text 莊子 that contains · forbidden characters.';
$subst = "<span>$&</span>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;