re = /((((http|https):\/{2})|www\.)+(([0-9a-z_-]+\.)+([0-9a-z_-]+)(:[0-9]+)?((\/([~0-9a-zA-Z\#\+\%@\.\/_-]+))?(\?[0-9a-zA-Z\+\%@\/&\[\];=_-]+)?)?))/im
str = 'www.google.com'
# Print the match result
str.match(re) do |match|
puts match.to_s
end