package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[$£€](?:\d{1,3},)*\d{1,3}(?:\.\d+)?|(?:\d{1,3},)*\d{1,3}(?:\.\d+)?[$£€]$`)
var str = `$2
2$
€2,000
2,000€
£3,000,000.15
3,000,000.15£`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}