$re = '/<\?php(.+?)\?>/i';
$str = '<?php some code in here ?> <?php some other code in here ?>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);