$re = '/^((09|\+639)|(|\d{2}|\d{3}))(-|\s)(\d{9}|\d{7})$/m';
$str = '+639 123456789
09 123456789
02 8324545
034 8324545
+639-123456789
09-123456789
02-8324545
034-8324545
asd
12341234
+63912345
0913456
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);