import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "vars\\/(prod\\S*|stage\\S*)\\/(mysql|keys).yml";
final String string = "vars/prod-region1/mysql.yml\n"
+ "vars/prod-region1/keys.yml\n"
+ "vars/prod-region1/test.yml\n"
+ "vars/stage-region2/mysql.yml\n"
+ "vars/stage-region2/keys.yml\n"
+ "vars/stage-region2/test.yml\n"
+ "vars/local/mysql.yml\n"
+ "vars/local/test.yml";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}