import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"personaname\":\\s\"([^\"]+)\"";
final String string = "{\n"
+ " \"response\": {\n"
+ " \"players\": [\n"
+ " {\n"
+ " \"profilestate\": 1,\n"
+ " \"personaname\": \"Furious Skunk\",\n"
+ " \"personastate\": 1,\n"
+ " \"primaryclanid\": \"103582221429719132\"\n"
+ " },\n"
+ " {\n"
+ " \"profilestate\": 1,\n"
+ " \"personaname\": \"Tom MLG 1337\",\n"
+ " \"personastate\": 1,\n"
+ " \"primaryclanid\": \"103582793333284766\"\n"
+ " },\n"
+ " {\n"
+ " \"profilestate\": 1,\n"
+ " \"personaname\": \"Mista Bombastic, reggae fantastic\",\n"
+ " \"personastate\": 1,\n"
+ " \"primaryclanid\": \"101182741435284766\"\n"
+ " }\n"
+ " ]\n"
+ " \n"
+ " }\n"
+ "}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}