package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[\u4e00-\u9fa5]{0,}$`)
var str = `多渠道无`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}