using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?:windows|remodeling)(?:\sin\s)?\s*(\w+)(?=\s(?:ny|texas|wa)|)";
string input = @"replacement windows in seattle wa
basement remodeling houston texas
siding contractor new york ny
windows in elk grove village";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}