use strict;
my $str = '[DatabaseGenerated(DatabaseGeneratedOption.None)]
public long Id { get; set; }
[Required]
[StringLength(15)]
public string Email { get; set; }
public string CellPhone { get; set; }
public int NumChildren { get; set; }
public DateTime BirthDate { get; set; }
/// <summary>
/// Base64
/// </summary>
public string Image { get; set; }
public List<FullSdnOption> Optionen { get; set; }';
my $regex = qr/ *((\/+.*\n*.*)|(\[.*\]\n*.*))*public [A-Za-z\_\?\<\>]* ([A-Za-z0-9\_]*) .*(\n| )*/imp;
my $subst = '$4 = person.$4,\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";