import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<form[^>]*>((?!<\\/form>).)*<\\/form>";
final String string = "<p>Hey I am a boy</p>\n"
+ "<form id='id1' class='class1'>Content</form>\n"
+ "<p>Hey I am a girl</p>\n"
+ "<form id='id1' class='class1'>content</form>";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}